Android IDE (AIDE) Support Forum

Aapt error after andoroid update

Hello,
I’ve been using AIDE for many years, never having problems with it.
Yesterday my phone updated from Android 10 to Android 11, and today when I try to run any of my apps I get the following error:

aapt error retrieving parent for item: No resource found that matches the given name 'android:Theme'

The resource not found changes from app to app, but ALL of them are not runing.

Somebody has the same problem in Android 11?

The device is XIaomi Redmi Note 8 Pro, MIUI 12.5, Android 11.

1 Like

I recently upgraded to Android 11, but I didn’t get this error. Maybe because I only use the v25 of support libraries. Try refreshing the libraries or reinstalling AIDE from the store.

Tried installing other IDEs and all give me the same error. Seems something with Xiaomi’s layer.

I’ll try making a project in v25, will post the results.

Didn’t work. all projects fail.AAPT cannot find the values for android:xxxx At least AIDE is working on an older phone(Xiaomi Note 3 Pro) and an ancient Tablet (Nexus 10).

My problem is now the RAM on those devices doesn’t allow me to debug the app (not enough to run both AIDE and the App at the same time).

continued triying to fix this,
Last attempt: “Install Termux, jdk and packages to compile and create apk.”.
Last Result: "Evene in Termux console “AAPT error, cannot find…”.

Any other Android 11 users who can run apps from AIDE?

THe steps to continue are: 1) Factory Reset, 2) Downgrade firmware.

Fixed, Factory Reset on device, and it’s compiling and running my projects again!